criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube

No credits or achievements

Has anyone else been experiencing having no credits or achievements after playing galactic assault for the past few days? Keeps saying round has ended??

Replies

  • Anyone??
  • Is this where it says no data available etc, if so its a known bug for any multiplayer mode after you have been in arcade.
    You need to log out of game and back in again for it to work, though it does occasionally pop up from time to time anyway.
    You still get the credits.
    Rebellions are built on hope.
    Rebel against EOR MM in the hope it gets removed.
  • Ah that would explain it then, thank you mate.
  • jonci
    719 posts Member
    No Problem, I would suggest searching the forums and looking for things already reported or commented on in the future, saves time in the long run, and trust me most subjects/ issues/ bugs in game have already been flogged to death here, most without any thing being done to fix the by the devs.
    Rebellions are built on hope.
    Rebel against EOR MM in the hope it gets removed.
  • bfloo
    13047 posts Member
    You still get them.

    They just don't show if you decide to play arcade.

    Maybe they'll fix it Soon™
    The Knights of Gareth are Eternal

    Pirate of the Knights of Gareth

    h846398gb27k.png


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!