criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Community Calendar

What has happened to the servers?

Prev1
Alwe15
2000 posts Member
I might be late to this discussion but since the TROS update I've found huge issues with server quality and ping.

I main Coop and haven't tried the other modes, yet. However, frequently the entire game either stops for a couple seconds or jumps a few frames suddenly. Once or twice the game has frozen for so long, it gives up trying and boots me back to the main menu.

What gives? Is this an EA server issue, a game issue or a "me" issue?

Replies

  • Nope. It’s really bad atm.
  • Alwe15
    2000 posts Member
    CC_1010 wrote: »
    Nope. It’s really bad atm.

    I'm linked to Germany which is apparently 22 ping. That, is a lie.
  • Alwe15 wrote: »
    CC_1010 wrote: »
    Nope. It’s really bad atm.

    I'm linked to Germany which is apparently 22 ping. That, is a lie.

    Same
  • Not sure if it's just the weekend or what.. but it's been unplayable for me. I've had to play other games instead.

    I tried co-op yesterday around 8 matches. 6 of them were terrible. I either got that bug where it only shows one class in the menu and freezes you from doing anything. Can't force a respawn or even pick a class. Or the match was extremely laggy.
  • IronSoldier
    3912 posts SWBF Senior Moderator
    I have also found server issues to be a thing more than previously.

    Played a lot of Apex the last few days then played HvV as Han this morning and I was like WOAH.

  • Alwe15
    2000 posts Member
    Meerkat wrote: »
    Not sure if it's just the weekend or what.. but it's been unplayable for me. I've had to play other games instead.

    I tried co-op yesterday around 8 matches. 6 of them were terrible. I either got that bug where it only shows one class in the menu and freezes you from doing anything. Can't force a respawn or even pick a class. Or the match was extremely laggy.

    I've not suffered that bug, yet. Weird.

    I've had the team swap bug though, when you end up on the AI team 😂

    Yes. Lots of ping related lag. 😔
  • Alwe15
    2000 posts Member
    I have also found server issues to be a thing more than previously.

    Played a lot of Apex the last few days then played HvV as Han this morning and I was like WOAH.

    Is there any word from the devs? You've got a direct Batphone haven't you 😉
  • Yes, the lag is bad. HvV sometimes is just a game of guessing when and if anything will work at all. Having come from Battlefield 1, I've found that EA/DICE servers significantly deteriorate over time (perhaps due to limited resources/maintenance) and with each patch/update. Another detrimental factor are high-pingers/out-of-region players who the netcode seems to favour.

    It's quite noticeable that complaints/threads about lag and/or bad server performance are never addressed. This is the same I experienced on the Battlefield 1 forum back in the day.
  • Yep, it's been a rubber band fest lately.

    Time for a hamster replacement.
  • It's been a on and off issue since the beginning
  • Alwe15
    2000 posts Member
    It's been a on and off issue since the beginning

    Really? I had some issues a while ago playing Starfighter Assault but this is the worst I've ever seen it. Considerably rubber band like 😔
  • It's been a on and off issue since the beginning

    For me, too. But it's gotten worse over time as well.
  • Hey guys, want to chime in and say that this is frustating af.

    Iam in Germany and play on, appearantly, german servers with 16 ping. PC.

    Yet in coop AI enemies yeet into hyperspeed sometimes and shots are very hard to hit.

    Same in PvP multiplayer.

    I really ask myself how players in PvP can reach +80 scores without hax and with this lag.
  • i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.
  • i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    Haven't played in 2 days but I often get 3 bar warnings but the bouncy bouncy happens when it's NOT showing.

    So even the message is lagged seemingly.
  • And the error 2495 is just another example of incompetence.

    There's no other excuse, devs should hang their heads in shame, but are more likely to be indignant that their three week christmas vacation is threatened
  • Lots o lag but without the "Slow Internet speed..." message popping up, oddly. Few things are more frustrating in this game than losing a fight due to server issues.
  • My friends and I are having issues getting kicked mid round. Sometimes it’s one of us. Sometimes 2/3 of us get kicked. No internet issues, no lag, it just suddenly freezes and then... back to menu.
  • i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    I get the connection bar in the top right but never drops to red. Can't imagine the rubber banding is less though.
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    Haven't played in 2 days but I often get 3 bar warnings but the bouncy bouncy happens when it's NOT showing.

    So even the message is lagged seemingly.

    The message seems to be a post event explanation for me. Almost like "oh sorry, your connection was bad, that's why your team mates jumped suddenly ahead of you".
    My friends and I are having issues getting kicked mid round. Sometimes it’s one of us. Sometimes 2/3 of us get kicked. No internet issues, no lag, it just suddenly freezes and then... back to menu.

    I think the kick back to menu is the worst of server connectivity. Almost like it can't catch you up to the gameplay so it just thinks, meh sod it 🤷🏼‍♂️
  • i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.
    Alwe15 wrote: »
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    I get the connection bar in the top right but never drops to red. Can't imagine the rubber banding is less though.
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    Haven't played in 2 days but I often get 3 bar warnings but the bouncy bouncy happens when it's NOT showing.

    So even the message is lagged seemingly.

    The message seems to be a post event explanation for me. Almost like "oh sorry, your connection was bad, that's why your team mates jumped suddenly ahead of you".
    My friends and I are having issues getting kicked mid round. Sometimes it’s one of us. Sometimes 2/3 of us get kicked. No internet issues, no lag, it just suddenly freezes and then... back to menu.

    I think the kick back to menu is the worst of server connectivity. Almost like it can't catch you up to the gameplay so it just thinks, meh sod it 🤷🏼‍♂️

    Have you both changed your server setting from default to manually selecting your nearest server? If you haven't, then that might explain the slow connection sign because it might be putting you in distant servers.

    Also I have noticed that even when I have selected my server, the game still sometimes throws an entire lobby into a foreign server and we all have to leave. Guessing perhaps once a round finishes, if there is a foreign player, then it might latch on to that person's location and select the next server for the next game based off of that person's location rather than the majority and then dump us all in it.

    So you're screwed either way sometimes haha.
  • i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.
    Alwe15 wrote: »
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    I get the connection bar in the top right but never drops to red. Can't imagine the rubber banding is less though.
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    Haven't played in 2 days but I often get 3 bar warnings but the bouncy bouncy happens when it's NOT showing.

    So even the message is lagged seemingly.

    The message seems to be a post event explanation for me. Almost like "oh sorry, your connection was bad, that's why your team mates jumped suddenly ahead of you".
    My friends and I are having issues getting kicked mid round. Sometimes it’s one of us. Sometimes 2/3 of us get kicked. No internet issues, no lag, it just suddenly freezes and then... back to menu.

    I think the kick back to menu is the worst of server connectivity. Almost like it can't catch you up to the gameplay so it just thinks, meh sod it 🤷🏼‍♂️

    Have you both changed your server setting from default to manually selecting your nearest server? If you haven't, then that might explain the slow connection sign because it might be putting you in distant servers.

    Also I have noticed that even when I have selected my server, the game still sometimes throws an entire lobby into a foreign server and we all have to leave. Guessing perhaps once a round finishes, if there is a foreign player, then it might latch on to that person's location and select the next server for the next game based off of that person's location rather than the majority and then dump us all in it.

    So you're screwed either way sometimes haha.

    Yes mate. Set to Germany at 22 ping apparently.

    It is every game now, so unless that is true for each match 🤷🏼‍♂️
  • Alwe15 wrote: »
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.
    Alwe15 wrote: »
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    I get the connection bar in the top right but never drops to red. Can't imagine the rubber banding is less though.
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    Haven't played in 2 days but I often get 3 bar warnings but the bouncy bouncy happens when it's NOT showing.

    So even the message is lagged seemingly.

    The message seems to be a post event explanation for me. Almost like "oh sorry, your connection was bad, that's why your team mates jumped suddenly ahead of you".
    My friends and I are having issues getting kicked mid round. Sometimes it’s one of us. Sometimes 2/3 of us get kicked. No internet issues, no lag, it just suddenly freezes and then... back to menu.

    I think the kick back to menu is the worst of server connectivity. Almost like it can't catch you up to the gameplay so it just thinks, meh sod it 🤷🏼‍♂️

    Have you both changed your server setting from default to manually selecting your nearest server? If you haven't, then that might explain the slow connection sign because it might be putting you in distant servers.

    Also I have noticed that even when I have selected my server, the game still sometimes throws an entire lobby into a foreign server and we all have to leave. Guessing perhaps once a round finishes, if there is a foreign player, then it might latch on to that person's location and select the next server for the next game based off of that person's location rather than the majority and then dump us all in it.

    So you're screwed either way sometimes haha.

    Yes mate. Set to Germany at 22 ping apparently.

    It is every game now, so unless that is true for each match 🤷🏼‍♂️

    Ok then I don't know how to go about fixing that. Seems like it shouldn't be happening.
  • Alwe15 wrote: »
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.
    Alwe15 wrote: »
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    I get the connection bar in the top right but never drops to red. Can't imagine the rubber banding is less though.
    i've lost connection at least half a dozen times today.

    does anyone else get the "slow connection may affect game play" in the top right of the screen? and the connection bars going from 4 to 1 (in red) every few seconds?
    I played for about 7 hours yesterday with zero issues.

    Haven't played in 2 days but I often get 3 bar warnings but the bouncy bouncy happens when it's NOT showing.

    So even the message is lagged seemingly.

    The message seems to be a post event explanation for me. Almost like "oh sorry, your connection was bad, that's why your team mates jumped suddenly ahead of you".
    My friends and I are having issues getting kicked mid round. Sometimes it’s one of us. Sometimes 2/3 of us get kicked. No internet issues, no lag, it just suddenly freezes and then... back to menu.

    I think the kick back to menu is the worst of server connectivity. Almost like it can't catch you up to the gameplay so it just thinks, meh sod it 🤷🏼‍♂️

    Have you both changed your server setting from default to manually selecting your nearest server? If you haven't, then that might explain the slow connection sign because it might be putting you in distant servers.

    Also I have noticed that even when I have selected my server, the game still sometimes throws an entire lobby into a foreign server and we all have to leave. Guessing perhaps once a round finishes, if there is a foreign player, then it might latch on to that person's location and select the next server for the next game based off of that person's location rather than the majority and then dump us all in it.

    So you're screwed either way sometimes haha.

    Yes mate. Set to Germany at 22 ping apparently.

    It is every game now, so unless that is true for each match 🤷🏼‍♂️

    Ok then I don't know how to go about fixing that. Seems like it shouldn't be happening.

    Thank you for the suggestion though mate. I'm hoping for some info from the team so 🤞🏼
  • ROMG4
    3504 posts Member
    Alwe15 wrote: »
    I might be late to this discussion but since the TROS update I've found huge issues with server quality and ping.

    I main Coop and haven't tried the other modes, yet. However, frequently the entire game either stops for a couple seconds or jumps a few frames suddenly. Once or twice the game has frozen for so long, it gives up trying and boots me back to the main menu.

    What gives? Is this an EA server issue, a game issue or a "me" issue?

    source.gif

    OOM-9 FOR LEGO STAR WARS
    OOM-9 Hero Concept by AzelfandQuilava
    https://i.redd.it/uleh1g22xrhz.png

    OOM-9 Canonical Material Check-List:

    Star Wars Episode 1: The Phantom Menace
    William Shakespeare's The Phantom of Menace: Star Wars Part the First
    Ultimate Star Wars (Reference Guide)
    Star Wars: On the Front Lines (Reference Guide)
    Darth Maul: "Who is supervising the search for the Gungan cities?" Nute Gunray: "Commander OOM-Nine." Darth Maul: "A droid. The predecessor of your inept B-Ones." Rune Haako: "A superior droid, Lord Maul. Viceroy Gunray's personal guard."
    Bring OOM-9, Hondo, Bo Katan, Mara Jade, Dengar, IG-88, Greedo, Zam Wessel General Veers, Tarkin and Rogue One, into the game we must. The way this is
    Tell Me. Have You Ever Heard Of The Tragedy Of Darth Coyler The Wise?
    A OOM-9 Thread!
    https://battlefront-forums.ea.com/discussion/150464/the-oom-9-campaigns-over-2-and-a-half-year-anniversary-thread

  • Alwe15
    2000 posts Member
    ROMG4 wrote: »
    Alwe15 wrote: »
    I might be late to this discussion but since the TROS update I've found huge issues with server quality and ping.

    I main Coop and haven't tried the other modes, yet. However, frequently the entire game either stops for a couple seconds or jumps a few frames suddenly. Once or twice the game has frozen for so long, it gives up trying and boots me back to the main menu.

    What gives? Is this an EA server issue, a game issue or a "me" issue?

    source.gif

    I love the gif but what does it mean in relation to this discussion? 🤷🏼‍♂️
  • Alwe15 wrote: »
    ROMG4 wrote: »
    Alwe15 wrote: »
    I might be late to this discussion but since the TROS update I've found huge issues with server quality and ping.

    I main Coop and haven't tried the other modes, yet. However, frequently the entire game either stops for a couple seconds or jumps a few frames suddenly. Once or twice the game has frozen for so long, it gives up trying and boots me back to the main menu.

    What gives? Is this an EA server issue, a game issue or a "me" issue?

    source.gif

    I love the gif but what does it mean in relation to this discussion? 🤷🏼‍♂️

    I think he's saying it's all fine for him.
  • Alwe15
    2000 posts Member
    Alwe15 wrote: »
    ROMG4 wrote: »
    Alwe15 wrote: »
    I might be late to this discussion but since the TROS update I've found huge issues with server quality and ping.

    I main Coop and haven't tried the other modes, yet. However, frequently the entire game either stops for a couple seconds or jumps a few frames suddenly. Once or twice the game has frozen for so long, it gives up trying and boots me back to the main menu.

    What gives? Is this an EA server issue, a game issue or a "me" issue?

    source.gif

    I love the gif but what does it mean in relation to this discussion? 🤷🏼‍♂️

    I think he's saying it's all fine for him.

    👍🏼

    Lucky for some.
  • This seems to be most prevalent in the EU and German servers seem to be hit the hardest.

    And because their are only German servers left, since they saved on server costs and pulped the UK servers, most of the EU plays on German servers now.

    EA seems to have a contract with AWS servers now and uses them to host both Battlefield 5 and Battlefront 2.

    To both games i have 15-16ms ping, no lag indicators or warnings, ever, in battlefield 5, esspecially planes (teleporting back and forth) and some players lag and yeet around like its an autism convention and in battlefront 2 it almost looks the same.

    I have a literally perfect 100mbit vdsl connection. A error rate on my connection between my modem and my DSLAM is pretty much non existent, with one error since 3 months, that looks to have came from the DSLAM also.

    So i would go on a limb here and say that the AWS servers they have contracted here in germany are pure trash.
    Or at least their peering/routing to the mayor ISP's.

    Iam on "Deutsche Telekom" btw. Biggest ISP in germany.
  • The servers for EA games are and have always been an issue for me. I'm on PS4 with a LAN cable on the US East Coast (Virginia) server that shows a ping as low as 14ms (though usually it's at 19ms). I have consistently dealt with lag/latency issues with every EA title I own (Battlefront 1&2, Battlefield 4 & 5) and any time I contact EA about it, it's always a problem with "my connection". If it was only happening with one of their titles, or if I dealt with these issues on any other non-EA game, then I'd be inclined to agree with them, but that's not the case. It's obviously not just an issue with my internet service.

    For the longest time, the issues were just a minor inconvenience and not game-breaking. Though as time has progressed it's only gotten worse. As of now, the server issues (combined with all the bugs) have sapped all the fun from the game and I only play a round or two before I give up and move on to something else. Whether it's a full clip/heat cycle into an enemy only to be shot twice by them and die, being shot while behind cover, stuttering and rubber banding, or having a pitched battle freeze up and kick me to the main menu, the frustration involved in playing this game has started to outweigh any enjoyment I get out of it. It's a shame. The game can be really fun when it's working as intended. Unfortunately, I can't remember the last time that was the case.
  • Alwe15
    2000 posts Member
    This seems to be most prevalent in the EU and German servers seem to be hit the hardest.

    And because their are only German servers left, since they saved on server costs and pulped the UK servers, most of the EU plays on German servers now.

    EA seems to have a contract with AWS servers now and uses them to host both Battlefield 5 and Battlefront 2.

    To both games i have 15-16ms ping, no lag indicators or warnings, ever, in battlefield 5, esspecially planes (teleporting back and forth) and some players lag and yeet around like its an autism convention and in battlefront 2 it almost looks the same.

    I have a literally perfect 100mbit vdsl connection. A error rate on my connection between my modem and my DSLAM is pretty much non existent, with one error since 3 months, that looks to have came from the DSLAM also.

    So i would go on a limb here and say that the AWS servers they have contracted here in germany are pure trash.
    Or at least their peering/routing to the mayor ISP's.

    Iam on "Deutsche Telekom" btw. Biggest ISP in germany.

    Do you know enough about servers to tell me whether I might have more success switching to a server further away?
  • Alwe15
    2000 posts Member
    The servers for EA games are and have always been an issue for me. I'm on PS4 with a LAN cable on the US East Coast (Virginia) server that shows a ping as low as 14ms (though usually it's at 19ms). I have consistently dealt with lag/latency issues with every EA title I own (Battlefront 1&2, Battlefield 4 & 5) and any time I contact EA about it, it's always a problem with "my connection". If it was only happening with one of their titles, or if I dealt with these issues on any other non-EA game, then I'd be inclined to agree with them, but that's not the case. It's obviously not just an issue with my internet service.

    For the longest time, the issues were just a minor inconvenience and not game-breaking. Though as time has progressed it's only gotten worse. As of now, the server issues (combined with all the bugs) have sapped all the fun from the game and I only play a round or two before I give up and move on to something else. Whether it's a full clip/heat cycle into an enemy only to be shot twice by them and die, being shot while behind cover, stuttering and rubber banding, or having a pitched battle freeze up and kick me to the main menu, the frustration involved in playing this game has started to outweigh any enjoyment I get out of it. It's a shame. The game can be really fun when it's working as intended. Unfortunately, I can't remember the last time that was the case.

    It hasn't got bad enough for me to quit. It's a recent problem for me and as SWBFII is the only game I play online, I've no idea how successful playing a different game might be.
  • Crazy... Prior to the TROS update, HvV was virtually unplayable for me. I'd all but given up trying to play the game. Since the update tho, it's been running great for me.
  • Alwe15
    2000 posts Member
    KZ_Toxic wrote: »
    Crazy... Prior to the TROS update, HvV was virtually unplayable for me. I'd all but given up trying to play the game. Since the update tho, it's been running great for me.

    Oh nice. Wish I was having the same luck.

    What server are you playing on?
  • Alwe15
    2000 posts Member
    Is this getting better, or worse?

    I'm having different results each match. Had a bloody awful match on Ajan Kloss.
  • Alwe15
    2000 posts Member
    Another awful match on Ajan Kloss.

    @EA_Tom, @IronSoldier or @F8RGE.

    What are the server issues we're experiencing?
  • Just played a game of COOP yesterday and sure enough, spot on headshots on AI not registering when using the speciallist class with the sniper laserrifle and AI was again yeeting into hyperdrive, popping up right behind you sometimes.
    I didnt even try PvP after that.
    I dont care if i loose, iam not that tryhard, but i surely would hope when hitting people or AI right in their noggins, shots would at least register.
  • ROMG4
    3504 posts Member
    I have noticed a lot of out of region players have been getting into my lobbies perhaps that could account for some of the lag
    OOM-9 FOR LEGO STAR WARS
    OOM-9 Hero Concept by AzelfandQuilava
    https://i.redd.it/uleh1g22xrhz.png

    OOM-9 Canonical Material Check-List:

    Star Wars Episode 1: The Phantom Menace
    William Shakespeare's The Phantom of Menace: Star Wars Part the First
    Ultimate Star Wars (Reference Guide)
    Star Wars: On the Front Lines (Reference Guide)
    Darth Maul: "Who is supervising the search for the Gungan cities?" Nute Gunray: "Commander OOM-Nine." Darth Maul: "A droid. The predecessor of your inept B-Ones." Rune Haako: "A superior droid, Lord Maul. Viceroy Gunray's personal guard."
    Bring OOM-9, Hondo, Bo Katan, Mara Jade, Dengar, IG-88, Greedo, Zam Wessel General Veers, Tarkin and Rogue One, into the game we must. The way this is
    Tell Me. Have You Ever Heard Of The Tragedy Of Darth Coyler The Wise?
    A OOM-9 Thread!
    https://battlefront-forums.ea.com/discussion/150464/the-oom-9-campaigns-over-2-and-a-half-year-anniversary-thread

  • I had lag yesterday as well. The game was playable, but just barely. Spikes of higher lag would come in and just ruined the fun.
  • Alwe15
    2000 posts Member
    ROMG4 wrote: »
    I have noticed a lot of out of region players have been getting into my lobbies perhaps that could account for some of the lag

    How can u tell?
  • Alwe15 wrote: »
    Another awful match on Ajan Kloss.

    @EA_Tom, @IronSoldier or @F8RGE.

    What are the server issues we're experiencing?

    By far the worst map for me lag wise and strange loose gameplay.
  • StarLillie
    366 posts Member
    edited January 14
    ROMG4 wrote: »
    I have noticed a lot of out of region players have been getting into my lobbies perhaps that could account for some of the lag

    That's what I assumed too, when I group with someone further away the lag increases.
    Otherwise I also saw improvements after the update. Especially noticeable on Felucia.
  • jonci
    1266 posts Member
    Some one prolly set up a max player count for connecting to servers, only once those 24 have finished is it time for the next 24 players to have a game. Any more than that and game over looooooool.
  • All last week, and currently, I have gotten kicked from every match (okay okay, like 8/10 matches). Sometimes its in the middle of a match, and sometimes it kicks me from the map loading screen! I can maaaybe get 2 complete rounds in a row without issue, but then the next match... *loading screen* then I will have server issues the rest of the day.

    We (myself and 2 roomies) play online together a lot, and sometimes its one of us that gets kicked (but remain in a group), and sometimes its 2/3 of us. Not that it matters much, because the third usually gets kicked eventually too, and ironically enough, when one of us finally rejoins. It's so bad that it immediately kicks you when you hit join sometimes. The map screen will begin loading for 1 second, but then kick back to the main menu (5 times in a row before I just gave up).

    It doesn't matter what game mode you are playing either. I've gotten kicked from Ewoks, HvV, GA, CS, Blast... Everything.
  • Maybe it’s part of their matchmaking, I’ve noticed that when I get a good server and things are good many times I get changed to a server with noobs and nothing registers, no card and low level guys seem to one hit everyone, the later it may flip flop and I’m one hitting people.
  • Maybe it’s part of their matchmaking, I’ve noticed that when I get a good server and things are good many times I get changed to a server with noobs and nothing registers, no card and low level guys seem to one hit everyone, the later it may flip flop and I’m one hitting people.

    Are you suggesting there is a built in handicap?
  • Nah I'm like 95% sure that the servers are using this matchmaking scheme. That EA has patented!
    Watch 6:20 to 8:20 Specifically!



    Basically the game puts you in games your going to likely lose and going to likely win because it has to try and keep people playing as long as possible. Also because it's probably an old matchmaking mechanic still left in the server that was intended to get DICE more lootbox transactions as the rest of the video talks about.

    The game has nothing that resembles fair or balanced matchmaking!
  • Ppong_Man12
    2924 posts Member
    edited January 17
    https://heavy.com/games/2018/01/ea-matchmaking-patent-microtransactions-loot-boxes/amp/

    https://wccftech.com/ea-matchmaking-algorithm/amp/


    Nah I'm like 95% sure that the servers are using this matchmaking scheme. That EA has patented!
    Watch 6:20 to 8:20 Specifically!



    Basically the game puts you in games your going to likely lose and going to likely win because it has to try and keep people playing as long as possible. Also because it's probably an old matchmaking mechanic still left in the server that was intended to get DICE more lootbox transactions as the rest of the video talks about.

    The game has nothing that resembles fair or balanced matchmaking!

    I’ve also read that. According to some genius apparently,.. players don’t tend to like competitive sweaty matches on average, they like the godlike arcade stomp. Now for the ones getting stomped,.. they may be more inclined to upgrade/spend money when available(no now of course), or be swapped after a while,( if getting stomped), to the winning side. Either way imo it’s a joke of a system.
  • Alwe15
    2000 posts Member
    That's not really what this thread is about guys...I'm talking about the obvious server issues which cause stuttering and rubber-banding.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!