criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Felucia Transmission
No Match for a Good Blaster

Unplayable game due lag

1356711

Replies

  • Same, I'm in the UK and have decent internet and usually get an ms of around 30 but this game just seems to constantly lag and freeze up with the 'Bad connection' message in the top right of the screen... I've tried port forwarding etc but nothing seems to fix it.

    No lag in Need for Speed and no lag playing PvZ Garden Warfare either, both on EA servers.

    Its a shame because when I get those periods with no lag the game is fantastic.
  • That's true, when I dont have that error on the upper right it plays amazing but this is just ruining the game for me I quitted so many times because its so frustrating the only game-mode I am capable of playing without getting it too much is fighter squadron lol..
  • The matchmaking is not sorting people by region. How on earth was this overlooked?!

    You can check your ping to confirm this on PC by opening the console with "~" and typing NetworkPerfOverlay.Enable 1

    Australian with constant 200+ ping. All other games 10-50max, including BF4.
  • I need to play multiplayer. but I still can not connect to EA Account. ):
  • Eggs_Benedict
    1 posts Member
    edited November 2015
    I'm having the same issue *most* of the time. After repeatedly restoring licenses and rebooting I am able to connect to smaller (sub 20 player) games. However, on average once per day I am able to connect to Walker Assault. However, when I leave that game and try to join another, I get the PSN connectivity issue.

    Most of the time, like I said, I'm experiencing this issue. I believe this is an EA problem because ALL of the other games I play online (COD, MGSV, GTAV, Diablo 3, etc.) work perfectly!

    EAStarWars twitter account has basically stopped replying to me and a few others about this problem. They referred me to technical support/customer service, but I was unable to be transferred to anyone (I tried to do live chat). From the sounds of it, however, it seems like it wouldn't have helped anyway.

    No one here is really talking about location. Could this be a regional/server issue? I'm on the PS4, Battlefront Deluxe Edition, playing from Canada, wired connection.

    Let's hope they figure out a fix soon!
  • Im surprised Im getting kills with the ridiculously laggy launch
  • I'm having this constantly, and it doesn't matter how I change my settings. I've power cycled my modem 3 times, and used multiple sources to test my speed. I run a 9ms ping connection with ~90MBit down and ~14 MBit up constantly. These connection issues seem to happen more in the intro of the game, making the first 2 or so minutes nearly unplayable. Usually it'll even out after that , but I occasionally have the connection issue warning pop up. It feels like I'm being connected to servers not within my region, but I cannot tell you that for a fact.
  • any one else getting this while in MP

    have high speed fiber optic internet

    up speed 75mbps

    down speed 14 mbps

    ping 10ms

    so i know it isnt anything to do at my end but my nephew who lives over 150 miles away and has a standard 15 mbps internet dont have any issues
  • I'm having the exact same issue.

    Time Warner in Brooklyn on a Medialink router. Both wired and wifi give me the same issue.

    All other multiplayer games work fine on my PS4
  • Bumping
  • I have the same issue, after a few rounds my complete internet networks goes wrong (DC from play, from PSN), and i need to completely restart P4 to solve the problem
  • Has this issue been resolved yet? I am still getting the error. In fact it has gotten worst as the week has progressed. What would only take 3 attempts to join any game type now takes 15-20 attempts.

    This is the only game I have had this issue on and there shouldn't have to be a work around of changing ports and such just to play a certain game. It should just work.
  • I have played many other EA games (madden, FIFA, etc.) and never had this problem. It has only happened with battlefront. This needs to be fixed. I shouldn't have to try 15-20 times to get into games that's stupid. It's almost 2016 not 1980.
  • When me and my husband try playing together(why we got the game) one of us gets a "Disconnected from EA servers" we have tried so many times!!!!!! When we play separate it's fine. The whole point was to play together. So ***** off!! It's not our internet or NAT type. Every other game works fine.
  • Any way to get this to the devs/admins? do they already know? I haven't seen much about this, but it seems like a lot of us are having the problem.
  • Is constantly happening to me as well. Considering asking for a refund of my money. Game is often unplayable. I am a decent fps player on others similar to this. I cannot get kills in this game. Its like they always see and shoot me before I see or can react to them. Im often finding myself shot dead "as" or "before" I've even rounded corners. Today is a great example. Played 3 matches and died like 40-50 times. 10 kills, all explosives. Could not get a weapon kill. Rubber banding at very inconvenient times and again, I cannot stress enough how it always feels like the enemy just seems to know what im doing, where I am, and when to shoot before I get chances to react. The culprit, to me, appears to be latency....
  • Same problem my internet connection is fine fast PING and hardwired to my modem ran absolutely beautifully in Beta never had an issue at all but the final release is really bad which is a real shame cause i would love to play this game.
  • Every single game it says I have a poor connection and it will affect gameplay. Usually at least every other game I will completely lose connection to EA. I have no problem playing games online like Starcraft 2 but this game must just have some super connection issues going on with their servers.
  • Check ur Nat type on ur xboxone, I was losing all my 1v1 gun fights n I knew summat was wrong so thought I'd check my Nat type n I was right it was moderate instead of open, no idea if that will help but worth looking at!
  • Ok so been doing more testing...

    Tried it again this evening and was still getting constant 'Bad connection to the server' messages.
    I then opened all the suggested ports in my router.
    Tried again, seemed ok for 5 minutes before getting the 'Bad' and 'Very Bad' connection messages again.

    I then displayed the MS graph to see what exactly is going on. My MS sits at 50 and every so often spikes to 100 (displays the 'Bad connection' message) and then will spike to 500 (displays the 'Very bad connection' message).

    I again tried other EA games I have and they all connect and play fine showing an MS of around 50 with no lag spikes or any lag at all.

    Failing to see how this cannot be anything other than an issue with the EA servers as there really isn't much more I can do on my end...
  • Exactly the same problem as you guys, its driving me crazy, I end up in game 1-19 etc etc, its so frustrating, every game type is the same, loading screen the "Bad Server Connection" blah blah, FIX THIS EA!
  • Help us, Obi-Wan Kenobi. You're our only hope.
  • Alright. I spent an hour and a half on the phone with an EA tech.

    They aren't really aware of the issue. He had me troubleshoot things in Ipconfig, my Modem, some EA tracing software to test connections. They want you to try opening ports and using a DMZ on your local IP to make sure the connections are clear.

    I did all this, so he was able to test EVERYTHING, and there were still problems.

    He recommended raising awareness here on the forums, as devs do, supposedly, read it. (where are you devs?)

    I think the more fuss we raise, the quicker the issue will get resolved. I recommend every ones tries opening your ports, and doing exceptions for the game on your firewall. DMZ your IP for this game. And then if that still doesn't work, and you want to call in personally, do that. Yes.. you will have to spent quite a bit of time troubleshooting. But you may be able to fix the problem to. Or if nothing else, it will help them find the problem and fix it.
  • Exactly the same problem as you guys, move on EA your game may be good the only time i could play it was by night at 3 or 4 in the morning. i want a refund!!!
  • Can we get a word on this? I am playing on PC which has the least amount of users and I get this message constantly. I have to spam my enter key to get into the game when it finally goes through. I had the same problems during the Beta but thought it would be fixed in the final release. Can we get an update on the situation please?
  • I have done all the troubleshooting possible, even contacted them on twitter after trying things left right and centre, no more answer from them apart from this one "EAStarWars ‏@EAStarWars Nov 19Thanks for the information. We will take a look and see what could be causing this."
  • Yea. we have to keep on them about this. The squeeky wheel gets the oil. The problem is no one is calling in about this. And that how they primary get word to the top techs about something being wrong.
  • I get this occasionally as well, though it seems to have increased in frequency since the 17th.
  • I seem to be able to get into fighter squadron a lot easier than others. Well after about 20 failed attempts it will let me into a game then give me a bad connection to server message and back to the main screen. This is my experience of this multiplayer game so far
  • This is the worst. I have no idea what I'm doing. I absolute DESPISE you Star Wars Battlefront!
  • The game is unplayable as every time it says "You have very bad connection with the server. The game will be unplayable". It happens every game. I connected my wifi modem to the PS4, I restarted the console and updated everything I could, but it still always has bad connection. Anyone else suffering because of this? Is it the curse of the launch? I hope EA fix it...
  • This is an issue here in the UK as well! I have 100 meg up and 50 down no modem just straight into cable and i get the same poor connection error! I'm not a conspiracy theorist but there is such a thing as lag compensation.

    Are us players with good connections being throttled? No of course not! ;)
  • Same here. Every other game I play online works fine. Same CRAP servers as BF4 I suppose.
  • I'm having the same issue. Disconnects before game start, PlayStation network disconnect or ea servers disconnect error. Using a wireless router.Never had this issue with destiny using the same router.
  • I find with Blast the lag is the worst - I cannot move at all. Other areas of the game are fine.
  • What is so bizarre is that I can also play Cargo but nothing else? How is this possible?
  • I'm not lagging, but I do get that in the top right corner now usually...
  • I'm assuming there is a high number of people that have the problem, but they are not being vocal about it. The more people who talk about this on the forums the sooner we'll get a fix.
  • Consider yourselves lucky those are good speeds. After upgrading modem I now get 175 down and 12 up (only 95 down before) on Comcrap. Hope to see a difference.

    They really need to bump the upload speed though... 12 is low if people are getting 18 up or higher. It's no fun dying after 1 or 2 split second hits while emptying whole clips into people that still escape with 10-20 health. Total *****.

    There's either netcode/hit detection issues or latency due to distance i.e. players on opposite coast or other continents. That's the problem with no local only server options or server browser.
  • Nope. Not one connection issue in a day of play. You know what that means...
  • dont worry i have the same problem on pc and many others be it ps4 pc many have the same problem like you
  • OMG is what 13 year old American girls and effeminate males say. Which are you ?
  • Thaladar
    10 posts Member
    edited November 2015
    Yes. We are seeing this issue. We have two PS4s in the same house, behind a single router. But the disconnects only happen when we are Partnered up trying to enter the same game. We can play independently and have absolutely no connection issues at all. But trying to play together in multiplayer results in one or both getting disconnected 19 times out of 20. Yes, it actually worked...once.

    Playing missions together - No problem
    Playing multiplayer solo - No problem
    Playing multiplayer at the same time, but independently - No problem
    Playing multiplayer together - Disconnect from Playstation and/or EA servers
    Playing multiplayer with others - No problem

    Sounds like bad network code when you have two consoles behind the same router. I remember Destiny went through a period with the same problem. Then magically they fixed it and it worked fine. Maybe DICE/EA can ask Bungie what they did to fix it.
  • ea_are_poison
    1 posts Member
    edited November 2015
    On day 2 of the game everything was fine. Then yesterday and today there is constant lag every single game. Every 10 seconds my player will slightly teleport as if going back in time. It makes the game unplayable and ive only ever experienced this type of lag with battlefield. It seems that cargo and drop zone are unaffected by this. Its funny weve been waiting so long for this game to come out and these ***** at ea cant even get one thing right. My ps4 down speed is around 15mbps and around 5mbps up. Yet every time i disconnect my router, unplug and restart everything ill go try playing and still lag. It seems whenever i play battlefront then test my internet connection it goes to 5mbps download and 500kbps up. Is this game just eating away at my internet? Seriously frustrating. Even on a wired connection with 40mbps download same thing
    Post edited by ea_are_poison on
  • Yeah, I am having this same issue. I have opened the graph that shows my ping and it shows i have 60 but then i get the bad connection and it goes up. I only have that issue on this game. Please EA/Dice Fix this. I enjoy the game when i can play but almost all of it is unplayable with this.
  • Setting a static IP on the PS4 and a DMZ on the modem for that IP fixed it for me
  • Luthienx wrote: »
    I'm assuming there is a high number of people that have the problem, but they are not being vocal about it. The more people who talk about this on the forums the sooner we'll get a fix.

    The guy on the phone said if they get calls its better. While he said they "check the forums" he also said I was the first one to report a problem like this. They had no clue about this, until earlier today when I called.
  • What's the number?
  • "Slow connection to server. This may affect your gameplay." Well it isn't my network, internet connection, or computer. Other games, streaming, etc work great. I can't perform any movement actions for more than a couple of seconds without getting some stuttering/rubber banding or whatever you want to call it.
  • What's the number?

    You have to create a support ticket, and they call you. Be prepared for LOTS of troubleshooting.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!