criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube

Hutt Contracts: Already Completed Contracts Showing as Incomplete **MERGED**

Straywalker
1034 posts Member
edited July 2016
Platform: PS4
Issue: Some of my Hutt contracts were done in and around the release of OR.. somewhere the counting got wrong when you did a reset of my level 58 to 50. the cards somehow got done and I`m using the weapons/starcards daily. But now they shows as incomplete in the ending summary of every game. so I got two old, already done contracts showing as "in progress" and only one of the new ones showing

I have reported those two earlier in a bug report, for showing less used criteria than required.

This is not a game breaker, just a small annoyance
Can you reproduce this issue 100% of the time: Yes
Details on how to reproduce the issue: End a game
Internet Service Provider (ISP): get
Connection Speed: to router: 250MB/150 MB - to PS4 9,8MB Cableconnection
Screenshots or Private video links: Upon request

[Moderator Note: Edited title for Merged Threads]
Playstation 4 fun :p Proud member of the 3PO community
Post edited by EA_Afista on

Replies

  • Platform: X1

    Issue: When on the main menu, it says I still have 2 items available. When I go look in the menu, there are no new items (I have already looked at or unlocked any available items). This yellow number will not go away. I also have a hutt contract that has been completed, I've earned the unlock, but it reads as if the contract is not complete in post game.

    Can you reproduce this issue 100% of the time: Yes

    Details on how to reproduce the issue: For the yellow unlock numbers, go to the collect section of the main menu, or the unlocks section in any match. For the hutt contract issue, look at that contract in the hutt contracts menu or see it in the post-game stats.

    Please fix this issue ASAP. It's not affecting general game play but it would be nice if the unlock system worked properly. Thanks!
  • Namir
    8 posts Member
    edited June 2016
    It's been like this ever since the release of the Outer Rim DLC. Those yellow numbers indicate the star cards and skin that are basically already in the game, and confirmed by the developers, but not you available for unlock. At the star cards it will be the Escapist trait, and at the skins it will be the female cyborg skin. And thus the 2 new items, you just don't see them yet, but they are there... in hiding...
    You believe the Empire is continually plotting to do harm. Let me tell you, your view of the Empire is far too dramatic. The Empire is a government. It keeps billions of beings fed and clothed. Day after day, year after year, on thousands of worlds, people live their lives under Imperial rule without seeing a stormtrooper or hearing a TIE fighter scream overhead.
  • I think there were issues with this in the last DLC and the changes that were made in one of the patches fixed that, but after the Bespin DLC my old Hutt Contracts are no longer displaying that they are completed during the post game display. The Outer Rim contracts are the ones being displayed and even though I have all of the items unlocked, they are displaying that they are still incomplete. This also means the current Hutt Contracts I am starting for the Bespin DLC are not displaying in the post game screen. Additionally even after every card had been unlocked and was available, the unlock screen indicated that there was one new item, when that wasn't the case.

    For the Bespin Walker Assault Map, right around the 2nd and 3rd chance for the Y-Wing attack, to the left area of the map from the Imperial perspective there is a flashing yellow light that looks like some kind of lighting error and isn't tied to the new Pulse Cannon glint. The light source looks almost like its originating off of the map and is very bright obscuring the screen and flashes randomly.
  • That's super annoying.
  • Platform: PC
    Haven't played the new maps enough to test how consistently this can be reproduced yet
    NA Region
    OS: Windows 10
    Graphics Card: GeForce GTX 960
    Processor: AMD FX-6300 Vishera

  • I'm having problems on Ps4 with star cards, I can only get 29 original star cards, number 30 doesn't appear even though it says I have 1 to claim.
  • yodajedifishmaster
    1361 posts Member
    edited June 2016
    platform : PC
    ISSUE: i have contracts showing for the DLT-19X and 2 other contracts which i have completed, and have the weapons unlocked but they are showing them with conditions to be met. none of the three show any progress when performing actions for new bespin contracts (e.g the cooling card uses does not increase from zero). i feel i should explain what i think has happened.

    these contracts were glitched and reset i think after a post outer rim patch to fix some issues. after that patch, these contract conditions seemed to be set to someone elses state OR reset - eg one showed 20/20 before the first patch after outer rim dlc came out, and after it reset to 0/20 but did not update. the weapon correctly is unlocked due to the contracts being met, but these contracts were stuck showing wrong condition states. the current issue is, because they show conditions not met they are the only 3 ever showing on the post match contracts status screen.

    i do not know how to correct this. i would rather not lose the weapons and have those 3 contracts reset in order to clear them from the screen and show actual unfinished contracts. somehow the game should maybe check to see which weapons are unlocked and then set the contracts for those weapons to show completed and not display in the contracts screen post match.

    reproduced 100% of the time after any match ends providing you dont skip to new map.
    invalid brain token
  • MinTuba
    98 posts Member
    I have this issue (with different contracts) on XB1. Except I sometimes would see new contract progress.
  • this isnt new for me. I've been seeing it since the outer rim dlc. now my old ones that were 100% are now saying im missing a kill or two here and there, but i can use that star card anyway. they botched the targeting on fighter squadron now too. i lock on, and fire to my hearts content only a few yards away from the enemy and i never land a shot and end up dying by a npc crashing into me. hurts my soul how awful they keep ruining everything they try to "enhance"

    if(huttContracts == 1){
    huttContracts.completed();
    }else{
    customers.dontBuy();
    }

    theres you some psuedo code dice. fix it already.
  • LOL you would think that they would have fixed this with the last game dlc.
    i expect there to be a lot of stressing and many upset people working on this game, for them to make it with so many problems and to have the same problems carry over.
    "With the Force, he has joined. Grieve, I will not"
  • Platform: PS4

    I'm experiencing this issue too. I have 2 old Hutt Contracts, Rodian Blaster & Hostile Negotiations, that I've completed a while ago yet showing as not met some of the criteria. Online and on the app, they show as completed, it's on the PS4 that they don't. It didn't bother me too much before the latest update because they weren't appearing at the end of each match but now they are appearing every match and means I don't get to see the legitimate contracts I'm trying to achieve.

    Also before and after the latest update, I'm being told there is 1 new Star Card to view however unless it's really hidden, I can't see it... I hoped the update would fix this but alas, no.
  • NICK-ALTMAN
    153 posts Member
    edited June 2016
    Here is my post on the same subject.
    So I have 4 Hutt contracts from Outer Rim DLC that I finished and unlocked the weapons and cards but the progress is stuck at some point.
    Targeting Trooper stuck at 13 headshots.
    Hostile Negotiations stuck at 0 smoke grenades and 0 flash grenades.
    Slugthrower stuck at 24 kills with CA-87 and 4 focus fire charges.
    Combat Rush II stuck at 6 adrenaline stims and 12 personal shields.
    With Bespin patch they have not been fixed.
    So now after every game I am watching at the progress of 3 old stuck contracts.
    Take a look here: https://postimg.org/image/phnx0zxs7/
    I tried doing the stuff of the stuck contracts maybe to finish them now. But it remains as it is.
    Can I have this fixed please?

    http://starwars.ea.com/starwars/battlefront/forums/discussion/47792/my-old-hutt-contacts-are-still-broken#latest
  • Same issue happens to me with the rodian blaster contract.
  • Halpen4
    380 posts Member
    Same issue on PS4, but this is going back to Outer Rim when Hutt Contract were first introduced. The Targetting Trooper has unlocked the companion app is correct, but stat bars are not showing full and end of round hutt result screen is 66 % complete for targetting trooper instead of 100%. Really thought this bug was getting taken care of for the May patch, but no. Now Bespin patch still no fix, huh? Is this not getting looked at?
  • Halpen4
    380 posts Member
    I would say I think the problem got caused when working on more than one contract at a time, with the same goals for different rewards. Seems to have caused the deciding of which contract got registered the stat a bit of confusion, even though we were told multiple contracts with same goals would count for both.
  • yodajedifishmaster
    1361 posts Member
    edited June 2016
    Halpen4 wrote: »
    I would say I think the problem got caused when working on more than one contract at a time, with the same goals for different rewards. Seems to have caused the deciding of which contract got registered the stat a bit of confusion, even though we were told multiple contracts with same goals would count for both.
    that makes some sense to me although i feel in my case it was that i got someone elses progress sent to my cards somehow after a post outer rim patch, and as the cards were unlocked the stats got stuck. and as the DLT-19X and dioxis II and rodian blaster contracts show progress needed due to glitch/progress shown reset, they are never off the screen. its an annoyance rather than critical to me; just slows me down joining the next match since i have to go into hutt contracts between games to check where i am on the ones i need to unlock still.

    invalid brain token
  • I'm seeing similar issues with Star Cards, following the Bespin update. The companion app on my iPad are showing the Hutt Contracts complete, but in the PS4 game, they are showing as incomplete.
  • I've got the same thing, Combat Rush 2 shows I have 16/20 Adrenaline Stims used, Rodian Blaster shows 16/30 Kills with Pistols on Blast. I have completed both of these and they are unlocked, the companion app and 'Career' on this website shows they are complete, but they still show as active contracts at the end of every round..................
  • LMR11367
    39 posts Member
    edited June 2016
    MY HUTT CONTRACTS FOR THE STIM II summary screens are stuck - even though I have used my personal shields more than 20 times - the contract is unlocked, I do in fact have the STIM II card - I've unlocked them - BUT the contract summary screen will not go away at the end of each round ??
    Larry
    MAY THE FORCE BE WITH YOU
  • Same for me on the PS4

    Platform: PS4
    Issue: STIM 2 card unlocked, but constantly saying its only 90% finished at the end of round summary
    Can you reproduce this issue 100% of the time: Yes
    Details on how to reproduce the issue: Finish a round. I have unlocked the Stim 2 card, but it still says I need to use a few more personal shields, and so it is constantly displayed as not completed at the end of round summary.

  • YES - same - shows I have used 7/20 personal shields - when i play I keep using the shields and they do not total toward the 20 needed- contract is STUCK - but unlocked. Contract Screen is horrible - 3 contracts show up on without enough time to read stats !!!! this is terrible !
    Larry
    MAY THE FORCE BE WITH YOU
  • Halpen4
    380 posts Member
    Me too for Target Trooper on hutt contract summary it shows 66 % even though I've unlocked the reward. The stats bars for headshot and kills is not showing up as complete full, will this never be fixed?
  • Halpen4
    380 posts Member
    LMR11367 wrote: »
    YES - same - shows I have used 7/20 personal shields - when i play I keep using the shields and they do not total toward the 20 needed- contract is STUCK - but unlocked. Contract Screen is horrible - 3 contracts show up on without enough time to read stats !!!! this is terrible !

    Yeah, what do they think happens to the fourth contract, if we've got more than 3 going at once. It's strange too cause if I check on the pause screen I can scroll down and see all of them, but it's strange cause my 66% targetting trooper contract does NOT show up on this list. Maybe cause I've completed it, but at the summary screen it shows only 66 % .
  • Platform: X1

    Issue: Although I've completed this contract and have been awarded the blaster, it still shows up as me only having 24/30 kills with pistols on blast completed.

    Can you reproduce this issue 100% of the time: Yes

    Details on how to reproduce the issue: In the Hutt Contract menu it doesn't have a percentage completion number, but shows up as completed, but with only 24/30 kills with pistols on blast. The post-match Hutt Contract screen still has it show up after every match and getting more kills on blast with pistols doesn't make it go away. Like I said, I have already been awarded the blaster and it even says it's completed on the mobile app, just not on the console.

    This is just annoying and has been going on since the outer rim dlc came out.
  • briandt75
    5610 posts Member
    Why can't they get this right? It still shows 86% on some contract I finished a long, long time ago.
    41st Forum Fury Battalion Member
  • I also get this problem while I'm playing. Although its not a BIG issue. It still gets on some peoples nerves. Should defenitely fix this in my opinion

  • Really? Mine are all gone....
    tumblr_mvemcyarmn1rslphyo1_400.gif
  • LMR11367
    39 posts Member
    Also - my USE 20 ION SHOTS is still stuck at 1/20 - I have used DOZENS of them and the contract should now be unlocks for the EMP II
    Larry
    MAY THE FORCE BE WITH YOU
  • I'm having the same issue on the PS4. I have completed the hutt contract for the Rodian Blaster but it still pops up at the end of matches and in the Hutt Contract menu as 29/30 blaster pistol kills in Blast. I have the gun and everything. Happy to share images of this.
  • Hi,

    After every match when I see the scores I get two completed Hutt contracts (Slugthrower and Targeting Trooper) that shows as 93%.

    I have completed all Hutt contracts and have the Scatter gun and DLT19x in my inventory.
    Targeting trooper claims I miss two head shots, but new head shots are not counted.
    Slugthrower claims I miss 4 kills with the CA-87, but new kills are not counted.
    Targeting Trooper
    Slugthrower
    Please update my account so these contracts show as completed.

    ---
    Morten
    ---
    Morten
  • I am playing on PS4
    ---
    Morten
  • Stalemate
    3600 posts Member
    I have the same issue. I have completed all Hutt Contracts but 3 show as not completed after every single game. I am also on PS4.
  • Same here... Atleast remove the completed hutt contracts that shows each round so we can forget that stu pid bug -.-
  • Kunai013
    46 posts Member
    Same issue on Xbox One. Mine is with the dioxys grenade Hutt contract from OR. Apparently I need more kills with it, which I got. Still showing 94% but I have it unlocked and getting more kills with it doesn't change the accomplishment stat.
  • So completed security II hutt contract today and my progress is frozen on 47/50 stun / shock grenade bonus even though it has given me the upgraded card, the contract wont show as completed.. my Dad also has the same problem but with Hostile Negotiations... SORT IT OUT.... please..

    other bugs ive noticed heros v villains heros freeze in particular luke and you cant do anything attack, defend run or jump out of the way.

    And what on earth have they done to the pulse cannon? i cant hit anything with it now??

    Someone please reply so i know whats gonna be done :) Thank you..

    Darren
  • Redjensc
    0 posts Member
    edited July 2016
    Platform: PS4

    Issue: Combat Rush II progress reporting inaccurately in game. When viewing the Hutt Contracts in game it shows that I have used 4/20 adrenaline stims. I have used far more than that, and the companion app shows it as being achieved (>20/20). This results in the in-game menu showing that I have 1 card to unlock, but I have already unlocked it. I appear to have the upgraded card.

    Can you reproduce this issue 100% of the time: Yes

    Details on how to reproduce the issue: It reproduces the same result on its own

    If you're having connectivity problems or issues in regards to lag etc. please provide the following:
    Region: NA, and sometimes, doesn't affect cards

    Internet Service Provider (ISP): Mediacom
  • Platform:
    PS4

    Issue:
    The Disruptor II Hutt Contract was awarded, but still shows 50/50 Overheat Bonus, 19,430/20,000 Score As Any Hero. This wouldn't be an issue except it shows at the end of every game (annoying) preventing other Hutt Contracts from being displayed on-screen.

    Details on how to reproduce the issue:
    I believe this happened when I exited at the end of a game (after the last round had completed) of Heroes vs. Villains. I exited using the "O" (with confirming with "X") option before the round awards and score/contracts had been displayed.

    Regin:
    NA

    Internet Service Provider (ISP):
    Comcast

    Connection Speed:
    Ping: 31ms
    Download: 125 Mbps
    Upload: 12 Mbps

    Screenshots or Private video links:
    I can provide if desired.

    Processor (CPU):
    N/A

    Graphics Card (GPU):
    N/A

    Memory:
    N/A

    Operating System:
    PS4 System Software 3.55
  • Same for me: Hutt Contract Messed Up
    Platform: XB1
    Issue: Progression not accurately tracked or reported.
    I have three contracts fullfilled, able to get reward, but progression bars show incomplete.
    I have a few more contracts, same issue.
    I have had two contracts that took me twice the completion to fulfilled (eg twice the rifle streak). I know this because in the game I hear Jabba laugh and message of contract fulfilled but then no reward (eg weapon unavail) but I kept at it and finally second time completing, finally got reward but progression bar never changed.
    Completely frustrating for an old uncoordinated guys playing up against the coordinated wipper snappers.
    For the love of Princess Leia bikini outfit get this fixed!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!