criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Welcome to the Star Wars Battlefront Forums. To help eliminate spam and fake accounts, you must have a linked EA account and own Star Wars Battlefront I or II to post on the relevant game boards.

Have issues posting, but own the game? Log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

Game won't start in Origin

it's 90min past release time (it's 1:34am PST ). My game won't start up in Origin. I open task manager and see it in there, it goes from 200mb to 444mb memory used, then closes and opens Origin window back up. I've tried going to folder and opening as Administrator....nothing. Rebooting PC (since installed just finished) nothing. Restarting Origin does nothing.

Anyone else having trouble?

Replies

  • also tried reinstalling Origin....nothing. My game is on a different drive from where Origin is installed, but hasn't affected any of my other games.
  • Hi Same problem here. i cant start it.
    When i klick on the Lunch/Play button it goes 10sec (the button is gray) then he turns back to normal collor.
    and nothing happend. runnig as an administrator not working.
    My Battlefield 1 runs whitout problem and the System requirement are the same.

    I need help
  • Hi I have same problem can t start from origin.

    It start to process when i click on icon or play it actually open a window star wars BF II... but only for 2 sec and than nothing.

    Win 7 64 bit user full admin rights ofc no idea what may i do... :)
  • Same problem when i a hit start it loads and says im playing BF2 but then it flips back to online again and i can click play....... What to do?
  • Did you all download the Trial or the Beta? I have the same problem as you and tried all suggestions and one worked. Go to C:, Program files (x86), Origin Games, Star Wars Battlefront II . . . Is there two applications in that folder? starwarsbattlefrontii and starwarsbattlefrontii_trial? Open up the trial application and BOOM! the game works. The sticky wicket appears to be a conflict between the two applications. Hope that works!
  • Ok i did that...now a ACTIVATE window pops up to enter product code. I got 3 emails yesterday...a confirmation... a preload is ready and then after 9pm...a " your preloaded game is now ready" None of these have my product code. I've always gotten one from games on Origin. Hmm.
  • Okay, from the Origin library, click the gear under the play button, game properties, is there a CD key there? Is so, copy and paste it into the activation screen you are getting.
  • Badkitty, is this on a laptop? The problems I have are on a laptop but the PC works fine.
  • there is no key...this is PC
  • Okay, is the play button on BFII orange? Asking because that usually means the game and the code is installed correctly. Did you purchase this game from Gamestop?
  • yea..orange play button. I purchased directly from origin.
  • Dang. So, when you click the gear on the BFII page, I get Epilepsy warning, cd key, and it says added to library on . . . , are any of those three items there?
  • Epilespy warning and game added to library...no key
  • Also, is there a General tab, Cloud saves tab, and advanced launch options tab above those three items? I haven't tried it yet, but if you click cloud saves there is an option to uncheck cloud saves and restore last local saved game. I think the entire problem that everyone is having is with the cloud sync thing.
  • Okay, that is why you get an activation page, no cd key. When you bought the game from origin, they send you a game code via email, have you tried redeeming it again? Top of page, Origin, redeem product code?
  • unclicked Cloud Save....nothing.
  • when i view game properties of my other games in list...they do show cdkeys. Hmmm. I paid by mastercard....maybe i have to wait for it to clear or something? I usually pay by debit.
  • Well, possibly a billing problem. Sucks though because the game goes live and you want to get in on it. I do suggest contacting Origin with your order info and a synopsis of what is going on but they are already getting hammered today with problems so it might take them a while to respond.
  • Seems like the billing portion is working though if the game shows up in your library, you were able to download it, and the play button is ready. Technically, sound like the cd key wasn't tied to the game from the purchase which is why it won't launch. On the activation screen you get when you click the trial application, is asks to insert the cd key, is that key in any email you have?
  • ya...i'm sitting in a 4min wait to talk to an advisor...so we'll see. Thanks for your help though.
  • No problem
  • i wonder if "minutes" is multiplied by some number for support....5min wait turned into 10...the guy said he'd be back in 2-3min to get the info..it's been 7...hmmmm :D
  • i have the same issue here. cant start the game.
  • Same here, what is going on... I can see that starwarsbattlefrontii.exe starts up, but quits after few seconds. Logs reveal nothing.
  • I went through an hour of SUpport....deleting origin folders in programdata and appdata folders,,,then uninstalling origin, reinstalling and restarting pc.. NOTHING !
  • contemplating just doing the refund....and buying the game from someone else so as to NOT go through origin.
  • Quick question to the others that posted here with same problem....under the PLAY button...click on the GEAR....goto GAME PROPERTIES.....under EPILEPSY WARNING....does it show your CDKEY ? it should, but does not on mine.
  • i just refunded the game. I'm pretty sure it's on their end. Even after my 1 hour support ticket chat...and i told them i had no cdkey in properties...i still don't. Now when i try to run the game..exactly the same thing happens. So because there is no cdkey...origin must be closing the game because we're not authorized. Doesn't matter to me now anyway. I'm buying from gamestop so i have a cdkey to redeem.
  • Badkitty
    27 posts Member
    edited November 2017
    ok...that did NOT solve the problem. I went to gamestop, purchased the game. Now i have a CDKEY. I redeemed that key for the game. Now under game properties it DOES show my cdkey that i just got.

    But alas..the game still frigging closes within 10seconds.

    #@&;$%#&^$%#&(^ !!!!!!

    One last thing to do, that i didn't want to do. Redownload the whole game. now i gotta wait 90mins again.
  • Yeah I think the key is not the issue. I bought a physical copy and the serial shows up correctly, still the same problem though.
  • Ok so reinstalling Origin and deleting all data DID fix the problem for me. It verified the installed files, complained about cloud settings not working and then booted. I did not have to redownload the game.
  • ya i tried that too...didn't complain about cloud save being off, but also wouldn't work when it was on.

    currently downloading...so we'll see in 90min
  • well..as of right now...it says "playable" while still downloading. So i hit play. Same thing, closes right away. sighhhh.
  • I did the same thing first, kind of suspect that this is what started the whole ordeal. If redownloading doesn't help, try once more to clear all origin stuff, download the installer (OriginThinSetup) and let it do its thing. This seemed to fix the bad state for me.
  • Badkitty
    27 posts Member
    edited November 2017
    I did it all again. This time after a full redownload of the game. deleted info, uninstalled origin. reboot. Reinstall origin, reload game...and verify files ....and..NOTHING !!
  • found a folder in documents that has the crashdump file.

    x5np6w.jpg

    tries to read\write info to a virtual address that doesn't have appropriate access too....hmmm
  • going back to support chat..but now the wait is 25min..i guess they're getting really busy! lol

  • I just found this post in another forum of someone who looked through their windows updates and noticed he had a ton to do. So he did each one , one by one..and found one that worked.

    I just did the same thing. I had 120 updates not installed but i searched for this ONE update.

    Platform Update for Windows (KB2670838). I am on windows 7 ultimate 64bit, your tag# may be different..

    But try this ! I only installed this ONE UPDATE ...rebooted, let windows install on startup...opened origin straight away and game WORKED !!!

    MY GAME WORKS NOW !
  • Glad it worked! Think I saw that Win 7 update fix somewhere but didn't think of it more since I'm on Win10 here... But the issues still seem to be related.
  • Hello,

    I was facing the same issue.

    Here is the list of steps I did to get it working (start with Chrome or Firefox).

    1) Uninstall the Origin program if it is not version 10.5.9.17903 - 0. Stop both processes before and remove the data in ProgramData\Origin

    2) Download the latest version (Originthinsetup) and install it. It will download a full version and allow you to reconnect. Most of your games will be there, some updates will be downloaded.

    3) Install the latest video drivers. My NVIDIA driver was not uptodate and guess what, the version 10 of Origin gave an error message !

    4) I had to install the latest Java version, just to allow the correct identification of the driver.

    5) Of course, Edge was pricky about the JAva, so I had to switch to Chrome, hence my proposal at the start.

    Afer upgrading and Origin, and Java, and Nvidia, and the latest games updates, guess what, the logo of SWBF2 finally did pop up.

    No need to refund, no need to get nervous, just foresee half a day of preparation, aside the download and its verification of course ...

    I hope this will solve your case too...
  • Badkitty wrote: »
    it's 90min past release time (it's 1:34am PST ). My game won't start up in Origin. I open task manager and see it in there, it goes from 200mb to 444mb memory used, then closes and opens Origin window back up. I've tried going to folder and opening as Administrator....nothing. Rebooting PC (since installed just finished) nothing. Restarting Origin does nothing.

    Anyone else having trouble?

    This happened to me a week ago. It’s a cloud syncing issue with your profile. The duration till you can play again varies. It’s a known issue and I’m sure it will get fixed ASAP. It Sucks trust me. For example in my case I couldn’t play for 20 hours.
    Origin ID: "NWG_DashYTGaming"

    Xbox Gtag: "DashYTGaming"

    Steam ID: "NWG_DashYTGaming"


    "When you ask for trouble, you should not be surprised when it finds you". - Plo Kloon

  • I've done all of these they didn't do a thing.
  • I had the issue where I click on Battlefront II in my game library and it would start the game for 1 second and crash. I fixed it by disabling Origin In Game.

    From the Game Library, right click the game, go to Game Properties
    Then uncheck the box Enable Origin In Game
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!