criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube

Battlefront 2 stuttering and has unbearable lag. Help.

I bought battlefront 2 and it’s was running smoothly for a while, then the game crashed and when I reopened it, it’s just a laggy mess. The droid that moves in the background of the home screen? Moves less than a centimeter every second. Can’t play multiplayer because the lag is that bad, and has delay while hovering over things. It’s not a me problem, because I played it fine yesterday for almost 10 hours. I have uninstalled the game and reinstalled, that didn’t fix anything I have rebooted my computer and router so many times and it still doesn’t work. I have the specs to play it, and I really want to, but with the lag I get it’s unplayable can’t even move my charecter. And I know this is in the wrong area, but it won’t let me choose another one. Thanks for any help I get.

Replies

  • You got ripped off like the rest of us...so disappointing....so unplayable...the Force is not strong in this game.
  • Danxoln
    2256 posts Member
    Yeah I've been experiencing some intense rubber banding the last couple days as well
  • Massive stuttering for me. If it wasn't for the stuttering it would be a smooth 60fps but it was unplayable for me today. The first game never has this problem and also looks better. What happened? I get tons of aliasing and shimmering on even the high AA setting. I'd tolerate it if I could just get rid of the stuttering. fx8350, win10, 16gb, 980ti 6gb
  • try deleting the config files in Documents
  • same problem for me :/
    massive suttering since last jedi update this week , I m so dispointed :(
    (gtx 1070 , i7@4.5 Ghz and 16 Gb)
    I play Full HD and I ve not this stuttering before update
  • I've been having the same issues. Sometimes it's smooth but recently it has become unplayable, my fps counter says 70 fps but the animations in the meny lags and look like 10 fps
  • BaronVonGoon
    98 posts Member
    edited December 2017
    You're not the only one. I'm on Xbox one x with that insane GPU and still lag and stutter and micor freeze. They turned on self destruct to spite us because of the microtransaction fiasco
  • the lag is unbearable i cant play the game like this i get frustrated when i even try to enter a game it kicks me out almost all the time and whe i do enter a game it lags like **** i tried lowering the graphics but that doesnt do anything otherwise great game but the lag makes it unplayable
  • Yep random fps drops for no reason gpu usage not even 100% game needs an optimization patch badly along side a huge server side fix for the lag. Gtx1080 at 2088mhz 7700k at 5gz so no reason to be stuttering and losing frames
  • You're not the only one. I'm on Xbox one x with that insane GPU and still lag and stutter and micor freeze. They turned on self destruct to spite us because of the microtransaction fiasco

    I'm on Xbox One X also and the stuttering the last couple days has been really bad.
    I wonder if it's cause more players joined after Christmas....
    Anyways I hope they fix it soon or they will lose many more
  • For me on pc, i discovered CPU usage spikes were a huge reason for stuttering, not just the server lag. You can use any cpu usage monitoring software to confirm that you aren't spiking to 100%. In Windows you can open the Task Manager and click on the Performance tab check that way. I was able to eliminate a lot of stutter by closing down web browser and other things i had open in the background. Now i always stay under 100% cpu usage on max gpu settings 4k. I only get stutter now from occasional latency, which is mostly in starfighter.
  • The lag is strong with this one.
  • The lag is strong with this one.

    "Explanation: It's just that... you have all these squishy parts, master. And all that water! How the constant sloshing doesn't drive you mad, I have no idea."

    - HK-47 to Revan
    giphy.gif
  • jetblade4
    1 posts Member
    edited January 5
    I HAVE A FIX

    got to the NVIDIA control panel and switch v-sync to adaptive, switch anisotropic sampling optimization to on, power management to prefer maximum performance, maximum pre-rendered frames to 3, and most important triple buffering to on. now in game disable DirectX 12 and your game should run smooth
  • for pc players using amd, go to radeon settings, gaming, global settings, turn off shader cache, then turn it back on (to amd optimized). this fixed all my stuttering problems and cut scenes finally play well again.
  • jetblade4 wrote: »
    I HAVE A FIX

    got to the NVIDIA control panel and switch v-sync to adaptive, switch anisotropic sampling optimization to on, power management to prefer maximum performance, maximum pre-rendered frames to 3, and most important triple buffering to on. now in game disable DirectX 12 and your game should run smooth

    v-sync to On... with your setting mentioned still ok


  • I've been playing fine for weeks, yesterday it says it needs a 3gig update, now it lagging in every game!!!
    Rubberbanding to the point of not wanting to play at all.
    Anyone know what to do?
  • I still get spikes of lag occasionally but switching to a new ping site was very helpful..... I think.
  • Darkaid
    9600 posts Member
    It's so annoying when I'm flying in SA and I just teleport all around the place and crash.
    Rest in peace, Carrie Fisher.
  • jetblade4 wrote: »
    I HAVE A FIX

    got to the NVIDIA control panel and switch v-sync to adaptive, switch anisotropic sampling optimization to on, power management to prefer maximum performance, maximum pre-rendered frames to 3, and most important triple buffering to on. now in game disable DirectX 12 and your game should run smooth


    THIS WORKED FOR ME OMG, THANK YOU!
  • jetblade4 wrote: »
    I HAVE A FIX

    got to the NVIDIA control panel and switch v-sync to adaptive, switch anisotropic sampling optimization to on, power management to prefer maximum performance, maximum pre-rendered frames to 3, and most important triple buffering to on. now in game disable DirectX 12 and your game should run smooth

    This worked for me, thank you!
  • this is very annoying i bought a xbox one x because I wanted the best experience to play molti plat games but instead I'm having the worst gaming experience battlefront 2 lags all over the place BF1 does the same thing??? does anyone know how to fix this problem???????
  • DEMOP wrote: »
    this is very annoying i bought a xbox one x because I wanted the best experience to play molti plat games but instead I'm having the worst gaming experience battlefront 2 lags all over the place BF1 does the same thing??? does anyone know how to fix this problem???????

    I have no idea, but make sure you try the basics if you haven't. Hard reset your console to clear your cache, and reset your internet. I know you probably already tried, but sometimes it slips people's minds.

    Have you tried out any other games with online play besides BF 1 and 2?
  • Bride
    1 posts Member
    hey guys, I solved this problem disabling the CPU hyper threading bios option...
  • u need better CPU
    CPU with 4 cores now get stuttering
    CPU with 6 cores are OK
    Many AAA games now need 6 cores
  • Kniphtee
    700 posts Member
    jcmo34 wrote: »
    You're not the only one. I'm on Xbox one x with that insane GPU and still lag and stutter and micor freeze. They turned on self destruct to spite us because of the microtransaction fiasco

    I'm on Xbox One X also and the stuttering the last couple days has been really bad.
    I wonder if it's cause more players joined after Christmas....
    Anyways I hope they fix it soon or they will lose many more

    Makes playing w/ skill cannons a loss - sniping w/ the specialist or Bossk's Relby etc. - precision is a waste.
    Just spray and pray - then turn it off and play a small game mode.
  • Had a lot of rubberbanding the other week on Xbox so I swapped from UK to Ireland server and that fixed it for me.
  • my PC started stuttering a few months back but I manged to fix it by going into Settings>Gaming, ensure that the record clip option is set to off and uncheck the two boxes beneath that after doing that my game now runs smooth as the day I bought it
  • Let's not necro/bump old threads.

    Thanks!

    Star Wars Battlefront Volunteer Moderator
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!