criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
November Community Calendar
Double XP Event

Servers lagging.

Im not sure if you all are aware of the issue but the servers are acting crazy. Just played 3 games with medium glitching/bug flashing making it impossible to play online.

Replies

  • i played last night and it was lagging and still is right now. and it seems to be affecting everyone in the matches im in too.
  • RenegadeNC
    51 posts Member
    edited November 2017
    The issue is that no matter where you're located in the US you'll be thrown into the same matchmaking pool for a CA data center! The in game "ping site" doesn't work so it doesn't matter that the one you have selected may have 30-50ms ping because you won't actually be connected to that one. Myself i'm averaging 150-180ms with 130ms being the lowest i've seen. My connection isn't the issue, speedtest.net and all my other games are working just fine with 30-60ms ping... Support is useless and can't help even when i've listed the IP to the CA data center that it's connecting me to: 159.153.38.49 (note to mods, that's the CA EA game server for others to see if it's connecting them to it as well).

    Try it yourself, open up resource monitor and click on the network tab, then select starwarsbattlefrontii.exe from the processes section, then when you're in game look in the TCP connections section and see if you aren't being connected to the same data center regardless of your location!

    6ec510c2db69fcd9283e25e1ee6077f2.png
  • +1 to Renegade

    I think the issue is indeed the ping sites... mine is set on Germany but am still getting random lag issues since pre-launch.
  • grizzly353
    1 posts Member
    edited November 2017
    I got the same issue with my ping located in Germany too. the game started well and then after 10 min : Error 327...
    For my 5 last games. WTF EA is wrong with ya guys ?
  • I've had the same issues since the weekend. Laggy, glitchy and overall annoying! Thought it was just on my end but then I hear all my buddies at the same time saying they thought they were getting kicked. I was really hoping this game was going to be my next addiction for a while but with the glitches and overall game play I'm heading back to bf1 to where I know what issues already exist!
  • reb1138 wrote: »
    +1 to Renegade

    I think the issue is indeed the ping sites... mine is set on Germany but am still getting random lag issues since pre-launch.

    I didn't realize it was an issue globally, damn...
  • Just played 3 games with medium glitching/bug flashing making it impossible to play online.

    I'm on the West Coast, USA and attached to the Portland ping, even tried the other global servers and found the same thing. The game has been flickering and stuttering on the PS4 nonstop in MP and even the Campaign the last few days. The MP Jakku map is the worst. Especially when I begin to use my weapons and abilities, my character freezes and I become a one-shot kill for another player. Happens every time. So, I don't think it's a server issue, but a game issue. And after the latest patch, the lag and stuttering is worse than before.

  • Just played 3 games with medium glitching/bug flashing making it impossible to play online.

    I'm on the West Coast, USA and attached to the Portland ping, even tried the other global servers and found the same thing. The game has been flickering and stuttering on the PS4 nonstop in MP and even the Campaign the last few days. The MP Jakku map is the worst. Especially when I begin to use my weapons and abilities, my character freezes and I become a one-shot kill for another player. Happens every time. So, I don't think it's a server issue, but a game issue. And after the latest patch, the lag and stuttering is worse than before.

    It would be nice if someone could use a laptop and connect their console through that ethernet port to see if consoles are connecting to the same data center as PC which is in CA. On the PC version at least, the "ping site" doesn't work and no matter where you are or what you do you'll always connect to the same 159.153.38.49 server in CA.
  • RenegadeNC wrote: »
    Just played 3 games with medium glitching/bug flashing making it impossible to play online.

    I'm on the West Coast, USA and attached to the Portland ping, even tried the other global servers and found the same thing. The game has been flickering and stuttering on the PS4 nonstop in MP and even the Campaign the last few days. The MP Jakku map is the worst. Especially when I begin to use my weapons and abilities, my character freezes and I become a one-shot kill for another player. Happens every time. So, I don't think it's a server issue, but a game issue. And after the latest patch, the lag and stuttering is worse than before.

    It would be nice if someone could use a laptop and connect their console through that ethernet port to see if consoles are connecting to the same data center as PC which is in CA. On the PC version at least, the "ping site" doesn't work and no matter where you are or what you do you'll always connect to the same 159.153.38.49 server in CA.

    I’m on Xbox One X and when I go to options, I select EA Account, then it shows me Ping Sites for Multiplayer. I live in Mississippi but I get the best ping from Virginia. Ohio is close to the same but Virginia is better for me.

    Long story short, when I select Virginia then exit the menu, when I come back in, for some reason it will change to South Africa where I have like 400-500ms! Lol... It will change to Ohio and Oregon as well. I can never get it to stay on Virginia. So I’ve tried to put it on Ohio, but it will change as well!

    The game is almost unbearable at times because of the rubber banding and lag that is present. In heroes vs villains, sometimes you’ll be swinging away on someone and they won’t take any damage but they just keep rolling and shooting you. It happens erratically and periodically. It doesn’t stay constant.

    And yes, I have QoS set up on my router so I know my Xbox is getting enough bandwidth. My nat type is open, everything is fine.

    There is something wrong with the game. Hit detection is off and it’s noticeably worse playing a melee hero than it is a ranged hero. They probably have ATT as their ISP...
Sign In or Register to comment.