criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Community Transmission
December CC

Missile lock will not lock on anything. Starts to, then immediately stops.

For days now everytime I play, I cannot lock onto anyone else with missile lock. It has nothing to do with other player's using anti lock upgrades, because it happens every single time no matter who or what I try to lock onto. Stationary turrets included. I've exited the game completely and restarted the game. Restarted my PS4 Pro. I uploaded two videos to my YouTube account that show what is happening (see links below).

As you can see, the missile lock starts to happen, but after a split second it just stops. I am able to shoot a missile straight ahead by double tapping, but this is obviously of little use in a fast paced game. This happens no matter which craft I fly with, and I tried deactivating all star cards and that didn't make a difference either.

I've tried searching but can't find any other reference to this issue. Has anyone else encountered this and/or know of a fix? Please help!



Replies

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!