criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Clone Commando Community Transmission
September Community Calendar

Problem with fullscreen

Hey guys!
Today I installed new battlefront and I've got a problem with full screen because game opened in window but in option is full screen. I can't change it. I use alt+enter, game settings and it doesn't work. Maybe someone know how it can be played in full screen ? :)

Replies

  • I'm not really sure what you're trying to say, are you saying you can't change the game settings from inside the game? Or is fullscreen giving issues when it is set to that?
  • I'm traying to say that inside the game option are on full screen but I think my computer open it in window and I can't change it :(
  • Alt tab then alt enter doesn't work?
  • no it dosen't :( in beta tests I've got the same but now i full version it is bad ;/
  • Why not use borderless windowed? It looks exactly like full screen, except for you can alt tab out to desktop much easier.
  • I've never heard about it I will try!
  • I used to use fullscreen all the time, then in some games like Ryse: Son of Rome for example won't work with alt tab if you want to go to desktop and search online for guides or locations of collectibles. Sometimes it even causes game to crash or freeze when I try to alt tab out with fullscreen. So I started using borderless windowed and it works like a charm, you can get into desktop instantly without any problems, and it looks nothing different from fullscreen.
  • I have this same probelm I use GF GTX 960m and when I have deskopt on 4k also in game have this same. When I try to change is still in 4k. Problem with fullscreen is with wrong name casue with windowbroder is fullscreen.
  • Same problem here, tried everything, now I'm playing with hidden start menu.. though some times the name bar on top of the window gets annoying..
    Does the borderless windows solve that? How do I set it?

    Thank you
  • I'm not sure what hidden start menu you are talking about, since I haven't experienced it (within borderless windowed mode). But you can set borderless windowed mode in the video options of the game, there's the 3 options : fullscreen, windowed, and borderless windowed; just choose the borderless windowed. I'm not sure if it will fix your menu problem, but you can give it a try.
  • Thanks guys! Borderless windowed works!! You need to set it in game and video option. Thank you again and may the force be with you! :smiley:
  • InLovingMemoryHD
    1 posts Member
    edited November 2015
    the borderless windowed mode will steal about 5-10 fps.
    any game that is not running in full screen mode will steal fps due that its not full screen. the pc is not giving a 100% attention to the game. it focuses on other things in the background..

    i play the same way.. set the start menu to "hidden" mode but still see the headline up there that says STAR WARS Battlefront..

    its set to full screen yet it starts like windowed mode.. but its full screen.. man is sounds wierd but thats it..

    if anyone comes up with something let us know.. thanks :neutral:
  • For me, I only lose about 2-3 fps, but that's true you lose a little bit of fps. But that's better than not being able to play at all if fullscreen is causing a "fatal" problem. This is just a temporary solution for those that are having problems with fullscreen, assuming they'll fix the problem, if not, then sucks for us.
  • I have the same probem and am not to fond of the full-screenwindowed mode.
  • Wiznak_TR
    4 posts Member
    edited November 2015
    same problem here :neutral:
  • OPEN Nvidia GeForce Experience and click optimize game
    All setting lower but FULLSCREEN Mod open :)
  • i have just upgraded my windows 8.1 to windows 10 and i can confirm that the fullscreen issue is solved by doing this upgarde. finnaly i can play fullscreen with high settings :smile:

    i had a similar issue in dragon age inquisition this game now allso works in fullscreen mode with windows 10

    problem solved :smile:
  • Do you have any Instant Message programmes running? I had a similar issue and it turned out skype was the culprit.
  • Thanks test
  • I am finding this to be a little annoying myself I shouldnt have to 1 upgrade my windows that kill kill the rest of my games just for this one to "work" right 2 run the game in boarderless mode just to make it look right to me that is not working right and isn't just a bug
  • This game gone from awesome to unplayable because of this random resolution to windowmode bug.

    tried both GeforceExperience optimal settings aswell as some settings fixes.
    I refuse to update to win10 - never seen bigger spyware in my life.
  • jmthsn wrote: »
    This game gone from awesome to unplayable because of this random resolution to windowmode bug.

    tried both GeforceExperience optimal settings aswell as some settings fixes.
    I refuse to update to win10 - never seen bigger spyware in my life.

    i totally agree with you but i guess there is no other solution then doing this update :-( at least for the moment... i really tried every possible troubleshooting nothing did help.

    please keep us up to date if you find one :smile:
  • Does it with Windows 10 too. Going to ask for a refund as I just bought it. Fk this.
  • same issue, but fixed closing teamviewer and skype, thats work for me.
  • dragon_FLI
    1 posts Member
    edited December 2015
    So as a fan I had to look this game over to buy. then i remember how i and a substantial amount of people who have bought another EA game, Dragon Age: inquisition, essentially got screwed over with a game not running on fullscreen and instead running on borderless window mode thinking it was the fix. this is the thread we started: http://answers.ea.com/t5/Dragon-Age-Inquisition/NVidia-Optimus-GTX00M-Cannot-Run-in-Fullscreen-Mode/td-p/3989581/highlight/false.

    It will highlight how borderless window mode with rob you of fps since its not true fullscreen. this matter was never really fixed more than a year ago. to think i would give another EA game a chance. im glad i looked this over if it had fullscreen issues for PC players ... especially those with gtx8xxm/gtx9xxm gpus & or optimus running on their laptop.

    tl:dr
    EA wont release a patch to fix your game. intel .. nvidia wont release a fix either. you will have to live with the fact you paid money for a game that wont run right. AND NO. the devs did not accidentally make a mistake with renaming full screen mode to borderless window vice versa in the settings... Playing borderless full screen mode takes away 5-10 fps from your game average.

    Im just putting this out there because even though the updated thread says upgrading to windows 10 fixed the dragon age no fullscreen problemes for some, battlefront as one person already reported isnt running true fullscreen on their windows 10.
  • same solution for me, thanks Shnaidar

    I disabled team viewer..works a treat.
    Specifically it's the option that allows you to share a window (small arrows in the top right of the window, which look like <-> )
    You can disable for specific apps but I just turned it off completely.
    cheers.
  • Samsung Magician caused Battlefront and Battlefield 4 to be unplayable in full screen and borderless with Windows 10.

    Exited the program (running in background) and poof all good.

    Good luck!
  • I don5 niviadia or whatever i have Intel on windows 10 my solution was to just play it in windowed regular windowed mode with no web pages or apps running its stupid you have to play with it like that
  • I can run fullscreen real fullscreen and it cases fatal lag help me if its possible
  • Hey, i actually found a solution which actually worked for me. I'm glad to help you all :))).
    So basically my problem was that Battlefield Hardline, nor Need for speed were going fullscreen even when i enabled it, even if i pressed alt enter. So i went to my nvidia settings and i remembered that i had boosted my Hz for a smoother image on my screen for my eyes, from 60hz to 75hz. And the way to fix this is by setting it back to its original settings. For me 60hz :). Thank you hope it helps :)
  • hupo11
    1 posts Member
    edited April 2016
    Where can i find my NVIDIA settings? I have the same peoblem in battlefront and need for speed.
    A few days ago fullscreen option in star wars battlefront worked but now it doesn't.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!