criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Community Transmission
December CC

Beta Challenges not completing

Hey all, I have the beta downloaded on my PS4, and I'm having trouble completing my last two challenges, the Quick Draw challenge, and the Take Aim challenge. I've noticed that it only counts the kills for those two if I use the Republic Officer pistol, and the Republic Specialist sniper rifle for each respective challenge. Is that how it works for everyone else, or is my beta glitched?


  • Only trouble I've had is that play both arcade modes.
    As for others they should be fixed but I recommend removing mods from your guns even if your not using the gun with mods. I got Stuck on heavy challenge till I removed my night vision scope from my cross era heavy blaster.
    What does DX in my name stand for?
  • For me I had to play Strike while using the base weapons.
    PSN: Trooper8059
    "Remember: Your focus determines your reality."
  • Only challange that i didnt complete (because of this bug) is the ” complete both arcade events ”. I played both arcade modes like 4 times and it did nothing.
  • Okay, I had to completely remove all of the modifications from some of the weapons, and now I was able to pick up one of the challenges. That seemed to do the trick. Thanks guys!
  • I've had problems with buggy challenges as well. Heck, I even had one of my star cards simply disappear out of my collection, which was a bummer because it was a Star Card that I really liked.
  • Thoix
    2 posts Member
    edited October 2017
    I can't complete Quick Draw or Heavy Trooper and I've tried everything to complete them. It's irritating.
  • I think it takes so long to do Quick Draw because you have to kill an opponent who is using the Officer Pistol, and they're pretty uncommon
  • nevermind. They're just bugged.
  • Use the base/default weapon for all classes. Finished mine in Strike mode.
  • Use the base/default weapon for all classes. Finished mine in Strike mode.

    It doesn't make a difference. I can't get it either way.
  • ifailed wrote: »
    Use the base/default weapon for all classes. Finished mine in Strike mode.

    It doesn't make a difference. I can't get it either way.

    dunno what problem you're having then

    i had to use the base weapon , no mods, hell its base so not even an option for a mod in order to complete them for all classes.
  • For Quick Draw, I've tried Arcade and Galactic Assault using both factions' base pistols and the modded ones and haven't gotten any progress. The heavy and assault weapons have stopped progressing as well, but I've managed to get the 50 specialist kills. Not sure what's going on.
  • dapperdroid
    1 posts Member
    edited October 2017
    I'm having the same trouble with Quick Draw and Heavy Trooper. Using the default long blaster let me complete Heavy Trooper; I was able to make some progress on Quick Draw using the default officer blaster pistol, but now it doesn't seem to be advancing any longer. I'm trying everything I can think of, from removing mods even though I am not using the Blurrg, to different game modes and unequipping all my star cards, but nothing is working. It's especially frustrating as this is the last challenge I need for the general ones.

    I also had problems with some of the daily challenges not counting progress, with star cards disappearing entirely, and with crates giving me two items instead of three.

    EDIT: Just wanted to update. I was finally able to complete Quick Draw by dipping into Strike and using the default officer pistol. Thank goodness this challenge is over!
    Post edited by dapperdroid on
  • Yes, quick draw and heavy rifle! Are the guns that the officer and heavy use not the right ones?? Please fix
Sign In or Register to comment.