criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Community Transmission
December CC

The Defender Milestone bug

so i am aiming for the multiplayer milestones and the last one i need is win as defender 5 times in SA the last map i need to win on is kamino, however today i focused on this i won 4 times as defender, at the end of each round it says milestone complete however i go to the career page and nope its not complete, any idea how to fix this?


  • I have encountered the same problem, and I'm sure many others have. Someone on a PS4 community I'm a part of claims that they got this fixed somehow, but I never heard how they got it fixed. I would definitely like this fixed as well.
  • Yeah im on pc and im in the exact same situation but i don't even remeber witch one i am suppose to win so i won them ALL like 2 times in a day and it is the last milestone that i need for the big one. Would realy be great if it could be fixed!
  • Try staying in the lobby for at least 2 more matches. It worked for me
    Ponds main

    Officer of The Knights of Gareth
  • So now i know that the one missing is ryloth for me but i tried your tweak Mastahpeece and it did not work. Well... They wil fix it.. soon.. Right? Right?? Right?????
  • My Aggressor did the same thing and my last battle was also Kamino. I think I quit out after winning it too if that helps.
  • I still don't have either the Aggressor or Defender milestones...
  • i've done it about 15 times now since i posted this, stayed in the same lobby for at least 3/4 matches after each win, contacted EA and just waiting the last few days for a response
  • Yep i already had send a bug report on that 5 day ago. I am just waiting for them to fix it (should not be that hard .. its not a major gameplay trouble.)
  • got a reply today - they said the fix will be dropping with the last jedi content
  • Awesome! They do take bugs and all in consideration realy fast.. the thing with boba fett hovering was fixed fastly enough and this one 6 days after i requested it (well it was probably there before but still!)
  • Try staying in the lobby for at least 2 more matches. It worked for me

    This worked for me.
  • Its done they fixed it! I just had to "update the game" on origin just before launching and it is now fixed!
Sign In or Register to comment.