criterion-sm dice-lg ea-starwars-lg instagram lucasfilm-lg motive-lg twitch you-tube
Felucia Transmission
No Match for a Good Blaster

Fps drops, game freezes and insane loading times (PC)

DinoWhale99
posts Member
edited January 31
Since the launch of the full game I have been expericing a lot of game freezes while playing. Although i can easily play the game on high with a stable 60 fps. While in the Open Beta I had no issue what so ever about frops frops, game freezes and insane loading times. And since shortly it takes me 7 minutes just to join a Galactic Assault match and when I finally join a match it's already over. So i am just curious what did they do, what the game made so laggy on the full release.

(I know, I have a bad pc but still)
Pc
RAM: 4 GB
Graphics card: GeForce GTX 1050 Ti
Processor: Intel (R) Core (TM) i5-2500 @ 3.30 GHz

Edited for language. - EA_Cian
Post edited by EA_Cian on

Replies

  • you are way below spec on your cpu and ram. min is a I5 6600 and 8 gigs of ram. 4 more gigs will help, 16 is the sweet spot for pc gaming now. I would look for a used I7 2700k. I would start with the memory first. it's your biggest problem for sure.
  • i have a i5 6600k with 16gb of ddr4 ram and gtx 1070 also files are on a ssd i have same problem and im running at 2k so graphics are well within my cards limits and iu have this problem too
  • Your RAM amount is killing you man. Your CPU and GPU can run the game ok on mid-range settings at 1080p but that 4GB if RAM is a huge performance killer for you. With that small amount your computer is constantly having to use your harddrive to compensate and that can cause all kinds of performance issues since HDD or even SSD drives are nowhere near as fast as most RAM. Upgrade to 8gb (I wouldn't bother with 16gb unless the other specs get an upgrade) and you should notice a world of difference.
  • i have 8 GB ram, but a second gen i7 and a gt555m. it can run on low but the loading times are super long, any idea what i should do?
  • AOD_RAKM3iST3R
    28 posts Member
    edited February 3
    same and my cpu even older but i can run at low fine, but since obi-update/Geonosis , same issues
    start "game" (exe) takes sometimes longgggg like 5min , or just freezes and crashed back to desktop.
    many times i start GA or HVV and loads map than freezes and kicked back to menu i am.
    disabled Dx12 , enable/disable origin ingame makes no diffrence, nor starting SWBF2 as admin , ive tested all such advice in the other thread. so since Geonosis i have these issues not before since i bought game in march 2018 and have 1500+ hours ingame. at the current time.
    ( edit:other times its within 1 min its loads to menu , or asometimes requires me to restart origin and such)

    [13:23:10] <RAKMEiSTER> OS: Unsupported Windows 10.0 (Build #17134) CPU: Intel Core2 Quad Q9550,  2.83 GHz, 6144 KB Video: NVIDIA GeForce GTX 550 Ti (1920x1200x32bpp 59Hz) Sound: Luidsprekers (High Definition A Memory: Used: 4022/8192MB Uptime: 2d 19h 43m 37s HD Space: Free: 1289.62 GB/3945.97 GB Connection: Linksys WMP600N draadloze N-PCI-adapter met Dual-Band-WFP 802.3 MAC Layer LightWeight Filter-0000 @ 450.0 Mbps (Rec: 1477.97MB Sent: 2163.67MB)



    Post edited by AOD_RAKM3iST3R on
  • jonci
    1105 posts Member
    I have similar issues and LAG.
    With
    Rampage v extreme x99MB.
    32GB *4x8) 2400Mhz CMK32GX4M4A2400C1 RAM
    Intel Core i7 5820K s2011 v3 OC to 4.6ghz
    970 EVO 1TB PCIE SSD
    850 EVO 1TB SSD
    EVGA 1080 TI Hybrid
    Corsair Hydro Series™ H150i PRO RGB 360mm Liquid CPU Cooler
  • AOD_RAKM3iST3R
    28 posts Member
    edited February 6
    this one solution i'm now trying // will report (EDIT) when i know if there is a real change , incl in cpu usage.

    https://answers.ea.com/t5/Technical-Issues/Battlefront-2-random-freeze-and-crash/m-p/6547313#M8311

    (and put the file " BootOptions" after change/save -> into "read-only" mode, so it remains on/after next reboot or game re-start.

    EDIT: so far works better. not hogging my CPU at 100% alltime GPU less also most times.. and had a good 6 matches hvv without any issue or not being kicked to menu on load new MAP.. etc etc etc.. 1st load game also normal..
    Post edited by AOD_RAKM3iST3R on
  • jonci
    1105 posts Member
    Worse last night 3 bars on Germany ping (default). Opposing teams were rubber banding, killed Leia in HVV within 2 seconds she appeared in front of me and killed me WTF. Thought they were using the old glitch of same characters in game, other people in game also complained about the LAG.

    Please sort it out the game is becoming unplayable.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!